首页 云服务器正文

使用rpm删除包的正确姿势

admin 云服务器 2020-06-24 07:33:10 32 0 云服务器

今天在虚拟机准备装Laravel,看了文档说是需要版本7.2.5以上,于是咔咔就需要更换php版本,然后就有了这篇文章。咔咔的所有文章都是根据一个问题的解决过程到解决最终方案的一个过程。如您只想知道结果可以直接看文末。

推荐教程:《Linux运维》《PHP教程》《Laravel教程》

一、使用rpm指令3秒删除PHP所有包

安装所有的框架和安装包时,第一个必须看的就是项目所需环境,可以看到Larave对PHP的版本要求是7.2.5以上。来到虚拟机看看PHP的版本,你可以通过php -v 来查看版本。

这里咔咔没有使用,PHP已经被咔咔删除了,这个指令执行不了了,尴尬。。。。

于是咔咔就用之前的rpm -qa | grep php指令显示的信息给大家展示一下咔咔之前的版本

这个版本是咔咔用rmp 安装的,所以也是需要使用rpm卸载的。此时的PHP所有的包都已经删除了

那咔咔是如何删除的呢!

还在使用rpm -e php70w....那就真的浪费时间了,大好时间不能用来放到删除文件上。

而且有的包时有依赖关系的,你在删除的时候肯定也遇到过这样的情况。

这个错误就是你需要卸载的安装包正在被别的包使用着,很烦是不是。咔咔教你使用一个指令来解决这些烦恼。rpm -e --nodeps rpm -qa | grep php

这个时候大概也就3秒左右就可以把PHP的所有安装包都给删除完。是不是非常的nice

在这里插入图片描述

二、rpm指令常用参数

rpm的主要功能就是安装、卸载、升级作用。

这里咔咔给大家整理几个常用的rpm参数使用。

  • -e 卸载rpm包
  • -i 安装rpm包
  • -u 升级rpm包
  • --nodeps 不验证软件包的依赖关系

这几个参数是咔咔经常使用的参数。

三、yum安装PHP7.2

安装源

rpm -Uvh https://dl.Fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-11.noarch.rpm
rpm -Uvh HTTPs://mirror.Webtatic.com/yum/el7/webtatic-release.rpm

或者使用这个也可以

yum install epel-release -y
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

安装所需要的扩展

yum -y install php72w php72w-cli php72w-fpm php72w-common php72w-devel php72w-embedded php72w-gd php72w-mbstring php72w-MySQLnd php72w-opCache php72w-pdo php72w-xml

执行完成之后查看版本号就是7.2了在浏览器里边就可以正常的访问了,Nginx是咔咔之前已经安装好了的。

【版权声明】

温馨提示:文章内容系作者个人观点,不代表seo教程网对观点赞同或支持。

版权声明:本文为转载文章,来源于金邦科技 ,版权归原作者所有,欢迎分享本文,转载请保留出处!

网址:www.15544.cn


本文链接:http://15544.cn/yfwq/66949.html

最新留言